Create on Transition missing links

Description

When the create issue on transition runs, the newly created ticket does not link to the original ticket and vice versa. There is no link being generated in the ticket.
In the post function is configured: Link:%original_key%, Link type: Relates, Link direction: From issue to new issue.

The Jira Application log shows the following:

2016-02-16 16:24:47,936 http-bio-127.0.0.1-8080-exec-3 ERROR dayers 984x30493x1 14fc4d2 10.102.94.150,127.0.0.1 /secure/CommentAssignIssue.jspa [jira.cot.functions.CreateIssueFunction] Ignore error finding issue link type: Relates when trying to add links for PWS-46058.

Environment

None

Activity

Show:
Bob Swift (Bob Swift Atlassian Apps)
February 16, 2016, 10:48 PM

Same comment as on your question since I saw that first:

To find correct link type names, to to Issue linking in Administration under Issues tab. You will need to use the Name field. Make sure your configuration matches (case sensitive) and neither your configuration or the configured link type have any leading blanks.

Dave Ayers
February 17, 2016, 3:07 PM

We had a leading space in the Relates field. Thanks for your help!

Bob Swift (Bob Swift Atlassian Apps)
February 17, 2016, 3:53 PM

Good! Yes, I thought I noticed the extra blank padding on the error message. This is a bit of a gripe I have that JIRA allows leading blanks in a number of constructs (probably just a oversight from years ago). Completely confuses people doing problem determination because the blank get hidden on display in most cases.

Resolved Locally

Assignee

Bob Swift (Bob Swift Atlassian Apps)

Reporter

Dave Ayers

Labels

None

Support Entitlement

None

Reviewers

None

Priority

Critical