Endless loop when using servicedesk.sh -a createRequest

Description

Endless loop when using servicedesk.sh -a createRequest

Not sure when this started, potentially after upgrade to jira 7.13.5 & servicedesk 3.16.5. Have tested latest atlassian-cli-8.7.0 and 8.8.0 snapshot. Was previously using 8.1.0.

atlassian-cli-8.7.0/servicedesk.sh -a createRequest --server http://jira-server/ --user Automation --password thePassword --components "Cloud" -f /tmp/test.txt --type "Priority 1 Incident" --priority "1 - Critical" --forUser alerts-noreply@mail.windowsazure.com --project SYKSD --organization "SYKOrg" --summary "[ALERT ACTIVATED] - Http5xx GreaterThan 150 (Count) in the last 5 minutes" -v
URL requested: http://jira-server/rest/servicedeskapi/latest/servicedesk
Request type: GET
Content type: application/json; charset=utf-8
Response code: 200, message: null, url: http://jira-server/rest/servicedeskapi/latest/servicedesk
URL requested: http://jira-server/rest/servicedeskapi/latest/servicedesk
Request type: GET
Content type: application/json; charset=utf-8
Response code: 200, message: null, url: http://jira-server/rest/servicedeskapi/latest/servicedesk
URL requested: http://jira-server/rest/servicedeskapi/latest/servicedesk
Request type: GET
Content type: application/json; charset=utf-8
Response code: 200, message: null, url: http://jira-server/rest/servicedeskapi/latest/servicedesk

Environment

jira cli plugin 8.7.0
Jira Software 7.13.5
JIRA Service Desk 3.16.5
atlassian-cli-8.7.0 & atlassian-cli-8.8.0-SNAPSHOT

Assignee

Bob Swift

Reporter

Chris House

Labels

None

Affects versions

Priority

Major
Configure