Availability

Blog

Blog


Overview

This page provides information about an individual release of the GINT - Groovy Integration Test Framework.

More release notes for additional versions of this product are available here.

Release Highlights

Release Date

2017-03-09

Version2.5.0
Purpose
  • Support testing of Confluence Connect macros
  • Atlassian Cloud testing improvements
  • Selenium testing improvements
  • Improved automatic screenshot naming
  • Global auto retry support
  • Retry on success closure failure
  • Added GintForJsap to support generic JSAP clients
  • Fixes

Additional Notes

Minor incompatibility for Selenium tests

GINT no longer will default Selenium tests to force maxParallel = 1 which prevents concurrent access to the browser. Tests must now explicitly set this concurrency level if needed. This is to support use cases where concurrency is possible provided there are other control mechanism used. For instance, Confluence Connect macro tests can use maxParallel values larger than 1.

Selenium tests needing concurrency control should do something like:

gint.initialize(seleniumHelper.getTestName(this))
gint.setMaxParallel(1) // prevent concurrent access to browser

Minor incompatibility for Confluence macro testing

GINT will now default macroPageBegin/End to blank. This makes it easier for Cloud testing and avoids need for Navigation add-on and it's scrollbar macro. See GINT-111 - Getting issue details... STATUS for more details.

Platforms and Compatibility

The following platforms were used during the development and testing of this release. We no longer test regularly on Windows even though it is fully supported platform.

Resolved Issues

T Key Summary Reporter P Status
Loading...
Refresh

Overview

This page provides information about an individual release of the GINT - Groovy Integration Test Framework.

More release notes for additional versions of this product are available here.

Release Highlights

Release Date

2015-04-18

Version2.3
Purpose

Platforms and Compatibility

The following platforms were used during the development and testing of this release. We no longer test regularly on Windows or Linux even though they are fully supported platforms.

Resolved Issues

T Key Summary Reporter P Status
Loading...
Refresh

Overview

This page provides information about an individual release of the GINT - Groovy Integration Test Framework.

More release notes for additional versions of this product are available here.

Release Highlights

Release Date

2014-11-25

Version2.2
Purpose
  • More Atlassian selenium support
  • Miscellaneous improvements
  • Fixes

Platforms and Compatibility

The following platforms were used during the development and testing of this release. We no longer test regularly on Windows or Linux even though they are fully supported platforms.

Resolved Issues

T Key Summary Reporter P Status
Loading...
Refresh

Overview

This page provides information about an individual release of the GINT - Groovy Integration Test Framework.

More release notes for additional versions of this product are available here.

Release Highlights

Release Date

2014-09-08

Version2.1
Purpose
  • Selenium for Atlassian helper to make it easier to write tests for Confluence, JIRA, and Bamboo
    • Login support
    • Plugin install tool support
    • Confluence Macro Browser testing support
    • Confluence Editor testing support
  • Option to clean output directory to reduce accumulating trash
  • Other fixes

Platforms and Compatibility

The following platforms were used during the development and testing of this release. We no longer test regularly on Windows or Linux even though they are fully supported platforms.

Resolved Issues

T Key Summary Reporter P Status
Loading...
Refresh

2013-05-05

Groovy 1.8

Because of GROOVY-4863, recommendation for running 1.8.x is to use at least 1.8.2.

Groovy 2.1

Also tested on Groovy 2.1.

Description

1.8.1 replaces and improves on 1.8.0 by adding fixes and reverting an incompatible change that has caused some difficulties.

  1. New support for writing testcases for Atlassian Stash® based on the new Bitbucket Command Line Interface (CLI)
  2. New support for writing testcases for Atlassian Crucible® based on Crucible Command Line Interface (CLI)
  3. Minor improvements and fixes - see issues for details.

Platforms

The following platforms were used during the development and testing of this release.

Jar built for Groovy 1.8.x and above

The 1.8.1 jar available for download is built using Groovy 1.8.x and must be used with Groovy 1.8 and higher.

On this page

Overview

This page provides links to recent Release Notes for individual releases of the GINT - Groovy Integration Test Framework.

Downloads

Release downloads are available through the Atlassian Marketplace, Bitbucket, or Downloads. In addition, Early Access Program (EAP) downloads are also periodically available here for use at your own discretion.

Release Notes

 Release Notes Archive

Issues

T Key Summary Reporter P Status Fix Version/s
Loading...
Refresh

2013-02-28

Groovy 1.8

Because of GROOVY-4863, recommendation for running 1.8.x is to use at least 1.8.2.

Groovy 2.1

Also tested on Groovy 2.1.

Description

  1. New support for writing testcases for Atlassian Stash® based on the new Bitbucket Command Line Interface (CLI)
  2. New support for writing testcases for Atlassian Crucible® based on Crucible Command Line Interface (CLI)
  3. Minor improvements and fixes - see issues for details.

Platforms

The following platforms were used during the development and testing of this release.

Jar built for Groovy 1.8.x and above

The 1.8.0 jar available for download is built using Groovy 1.8.x and must be used with Groovy 1.8 and higher.

On this page

Overview

This page provides links to recent Release Notes for individual releases of the GINT - Groovy Integration Test Framework.

Downloads

Release downloads are available through the Atlassian Marketplace, Bitbucket, or Downloads. In addition, Early Access Program (EAP) downloads are also periodically available here for use at your own discretion.

Release Notes

 Release Notes Archive

Issues

T Key Summary Assignee Reporter P Status Resolution Created Updated Due
Loading...
Refresh

2013-02-16

Groovy 1.8

Because of GROOVY-4863, recommendation for running 1.8.x is to use at least 1.8.2.

Description

  1. Retry conditioning - only retry if specific data is found in output, or data is not found in output
  2. GPathResult support in logWithFormat
  3. Confluence testing helper functions
  4. JIRA testing helper functions
  5. Minor improvements and fixes - see issues for details.

Platforms

The following platforms were used during the development and testing of this release.

Jar built for Groovy 1.8.x and above

The 1.7.0 jar available for download is built using Groovy 1.8.x and must be used with Groovy 1.8 and higher.

On this page

Overview

This page provides links to recent Release Notes for individual releases of the GINT - Groovy Integration Test Framework.

Downloads

Release downloads are available through the Atlassian Marketplace, Bitbucket, or Downloads. In addition, Early Access Program (EAP) downloads are also periodically available here for use at your own discretion.

Release Notes

 Release Notes Archive

Issues

T Key Summary Assignee Reporter P Status Resolution Created Updated Due
Loading...
Refresh

2012-12-02

Groovy 1.8

Because of GROOVY-4863, recommendation for running 1.8.x is to use at least 1.8.2.

Description

  1. Minor improvements - see issues for details.

Platforms

The following platforms were used during the development and testing of this release.

Jar built for Groovy 1.8.x and above

The 1.6.0 jar available for download is built using Groovy 1.8.x and must be used with Groovy 1.8 and higher.

 

Issues

T Key Summary Assignee Reporter P Status Resolution Created Updated Due
Loading...
Refresh

GINT - Groovy Integration Test Framework 1.5.0 is now available!

29 May 2012

Description

  1. Confluence 4.x support
  2. Simplified Confluence support with improved performance.
  3. Support for ordered searches for more accurate expected result matching.
  4. There are also minor improvements and fixes mostly driven by tests for Projects Using GINT.

Groovy 1.8

Because of GROOVY-4863, recommendation for running 1.8.x is to use at least 1.8.2.

Jar built with 1.8.x and above

The 1.5.0 jar available for download is built using Groovy 1.8.x and must be used with Groovy 1.8 and higher.

Platforms

The following platforms were used during the development and testing of this release.

 

 

Issues

T Key Summary Assignee Reporter P Status Resolution Created Updated Due
Loading...
Refresh

GINT - Groovy Integration Test Framework 1.4.0 is now available!

Feedback and support

  • Your feedback, comments, and ideas are important. Please help yourself and others by participating in discussions on the various pages.
  • Please report bugs, improvement ideas, or detailed support requests in JIRA.
  • Add comments to pages to report documentation problems.

Release notes

28 Nov 2011

Description

  1. With this release, GINT supports running Bamboo tests using GintForBamboo. This is similar to previous support for Confluence and JIRA. Groovy Tasks for Bamboo is a new project using GINT and provides an example test implemented with GintForBamboo.
  2. Support for Groovy Tasks for Bamboo
  3. Validated running build and test on Groovy 1.8.4.
  4. There are also minor improvements and fixes mostly driven by tests for Projects Using GINT.

Groovy 1.8

Because of GROOVY-4863, recommendation for running 1.8.x is to use at least 1.8.2.

Jar built with 1.7.x

The 1.4.0 jar available for download is built using Groovy 1.7 and is compatible with 1.8. You can build your own 1.8 specific jar, just note that it must be used with Groovy 1.8 and higher.

Future releases will require Groovy 1.8 and higher

Future releases will be built with Groovy 1.8 and therefore will require Groovy 1.8 or higher runtime.

Platforms

The following platforms were used during the development and testing of this release.

Bamboo Support For GINT

GINT has always supported continuous integration environments - Feature - JUnit-style XML output. The Groovy Tasks for Bamboo (1.1.0) adds a GINT task to make it easier to include GINT tests in Bamboo builds! GINT 1.4.0 is required for GINT tasks in Bamboo.

Issues

T Key Summary Assignee Reporter P Status Resolution Created Updated Due
Loading...
Refresh

GINT 1.3.0 is now available!

Feedback and support

  • Your feedback, comments, and ideas are important. Please help yourself and others by participating in discussions on the various pages.
  • Please report bugs, improvement ideas, or detailed support requests in JIRA.
  • Add comments to pages to report documentation problems.

GINT 1.2.0 is now available!

Feedback and support

  • Your feedback, comments, and ideas are important. Please help yourself and others by participating in discussions on the various pages.
  • Please report bugs, improvement ideas, or detailed support requests in JIRA.
  • Add comments to pages to report documentation problems.

GINT 1.1.0 is now available!

Feedback and support

  • Your feedback, comments, and ideas are important. Please help yourself and others by participating in discussions on the various pages.
  • Please report bugs, improvement ideas, or detailed support requests in JIRA.
  • Add comments to pages to report documentation problems.

GINT 1.0.0 is now available!

Feedback and support

  • Your feedback, comments, and ideas are important. Please help yourself and others by participating in discussions on the various pages.
  • Please report bugs, improvement ideas, or detailed support requests in JIRA.
  • Add comments to pages to report documentation problems.

Updates from release candidates

Significant improvements and changes were made since the release candidates. Some incompatible changes were made between the earlier release candidates and the final release. This was done to standardize interfaces and fix problems.

A release candidate for 1.0.0 is available. Please add comments to this post for discussions specific to this distribution . Feel free to open issues for specific problems (use 1.0.0-rc2 as affects version).

Release notes 1.0.0