Why Was JIRA 6.x Support Removed in CLI Release 6.0?

For the last few years, JIRA has been on a path to replace all remote access APIs with REST APIs. This was completed with the JIRA 7.0 release in 2015 and discussed in detail in our JIRA 7.0 Support Notice. Throughout CLI 5.x releases we have simultaneously supported both JIRA 6.x and JIRA 7.x (and Cloud of course). However, this made it more difficult to support new capabilities available in JIRA 7.x and Cloud. With the imminent end of life (EOL) of JIRA 6.4 (early 2017), we decided that this was the time to make the conversion to support only JIRA 7.0 and higher. CLI 5.7 continues to support JIRA 6.4 and this provides appropriate options for those customers still on JIRA 6.4.

Normally, CLI releases support a very wide range of Atlassian application releases. Tested releases are explicitly listed in our Compatibility Notes and, in many cases, the clients can be used against even earlier application releases. JIRA 7 is a unique case. This is not possible with JIRA and CLI 6.0 as we have explicitly required a JIRA 7.x or higher server or we fail the action. This was necessary due to the breakages between JIRA 6.x and JIRA 7.x and to protect customers from hitting too many restrictions and errors.